您現在的位置:程序化交易>> 期貨公式>> 文華財經>> 文華財經知識>>正文內容

我需要修改紅色的代碼導入WIN7可以使用 [文華財經]

  • 咨詢內容: ??DRAWRECTREL(0,0,990,990,RGB(20,18,12));DRAWTEXT_FIX(1,0.14,0.01,1,'東股份:',COLORRED;品種類型:=FINANCE(3);所屬板塊:=HYBLOCK;上市天數:=FINANCE(42);股總市值:=ROUND(FINANCE(41)/100000000);流通市值:=ROUND(FINANCE(40)/100000000);股東人數:=FINANCE(8);人均持股:=ROUND(FINANCE(7)/FINANCE(8));DRAWTEXT_FIX(1,0.14,0.15,1,'種類型:',COLORYELLOW;DRAWTEXT_FIX(1,0.14,0.25,1,'屬板塊:',COLORYELLOW;DRAWTEXT_FIX(1,0.14,0.35,1,'市天數:',COLORYELLOW;DRAWTEXT_FIX(1,0.14,0.45,1,'總市值:',COLORYELLOW;DRAWTEXT_FIX(1,0.14,0.55,1,'通市值:',COLORYELLOW;DRAWTEXT_FIX(1,0.14,0.65,1,'東人數:',COLORYELLOW;DRAWTEXT_FIX(1,0.14,0.75,1,'均持股:',COLORYELLOW;DRAWTEXT_FIX(1,0.23,0.25,1,HYBLOCK),COLORLIGREEN;DRAWNUMBER_FIX(1,0.2,0.35,1,上市天數),COLORWHITE;DRAWNUMBER_FIX(1,0.19,0.45,1,股總市值),COLORWHITE;DRAWNUMBER_FIX(1,0.19,0.55,1,流通市值),COLORWHITE;DRAWNUMBER_FIX(1,0.2,0.65,1,股東人數),COLORWHITE;DRAWNUMBER_FIX(1,0.2,0.75,1,人均持股),COLORWHITE;DRAWTEXT_FIX(品種類型=1,0.23,0.15,1,' 深 A 股',COLORMAGENTA;DRAWTEXT_FIX(品種類型=2,0.23,0.15,1,'中 小 板',COLORMAGENTA;
    ?
    DRAWTEXT_FIX(品種類型=3,0.23,0.15,1,'創 業 板',COLORMAGENTA;DRAWTEXT_FIX(1,0.23,0.35,1,'',COLORCYAN;DRAWTEXT_FIX(1,0.23,0.45,1,'元',COLORCYAN;DRAWTEXT_FIX(1,0.23,0.55,1,'元',COLORCYAN;DRAWTEXT_FIX(1,0.23,0.65,1,'',COLORCYAN;DRAWTEXT_FIX(1,0.23,0.75,1,'',COLORCYAN;DRAWTEXT_FIX(1,0.326,0.01,1,'績指標:',COLORRED;凈資收益率:=(FINANCE(33)/FINANCE(34)*100);銷售毛利率:=((FINANCE(20)-FINANCE(21))/FINANCE(20)*100);凈利潤比率:=(FINANCE(30)/FINANCE(20)*100);主營利潤率:=(FINANCE(23)/FINANCE(20)*100);優質資產率:=((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19));現金負債比:=(FINANCE(25)/FINANCE(15));凈利同增率:=FINANCE(43);?DRAWTEXT_FIX(1,0.34,0.15,1,'資收益率:',COLORYELLOW;DRAWTEXT_FIX(1,0.34,0.25,1,'售毛利率:',COLORYELLOW;DRAWTEXT_FIX(1,0.34,0.35,1,'利潤率 :',COLORYELLOW;DRAWTEXT_FIX(1,0.34,0.45,1,'營利潤率:',COLORYELLOW;DRAWTEXT_FIX(1,0.34,0.55,1,'質資產率:',COLORYELLOW;DRAWTEXT_FIX(1,0.34,0.65,1,'金負債比:',COLORYELLOW;DRAWTEXT_FIX(1,0.34,0.75,1,'利同增率:',COLORYELLOW;DRAWNUMBER_FIX(1,0.4,0.15,1,凈資收益率),COLORWHITE;DRAWNUMBER_FIX(1,0.4,0.25,1,銷售毛利率),COLORWHITE;DRAWNUMBER_FIX(1,0.4,0.35,1,凈利潤比率),COLORWHITE;DRAWNUMBER_FIX(1,0.4,0.45,1,主營利潤率),COLORWHITE;DRAWNUMBER_FIX(1,0.4,0.55,1,優質資產率),COLORWHITE;DRAWNUMBER_FIX(1,0.4,0.65,1,現金負債比),COLORWHITE;DRAWNUMBER_FIX(1,0.4,0.75,1,凈利同增率),COLORWHITE;DRAWTEXT_FIX(1,0.498,0.01,1,'務指標:',COLORRED;市凈率:=CONST(DYNAINFO(7) / FINANCE(34));市銷率:=CONST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));每股收益季:=CONST(FINANCE(33)/(5-FINANCE(37)));每股收益年:=CONST(FINANCE(33));每股現金流:=CONST((FINANCE(25)/FINANCE(1)));每股未分配:=CONST(FINANCE(32));每股公積金:=CONST(FINANCE(18));DRAWTEXT_FIX(1,0.51,0.15,1,'凈率 :',COLORYELLOW;DRAWTEXT_FIX(1,0.51,0.25,1,'銷率 :',COLORYELLOW;DRAWTEXT_FIX(1,0.51,0.35,1,'股收益季:',COLORYELLOW;DRAWTEXT_FIX(1,0.51,0.45,1,'股收益年:',COLORYELLOW;DRAWTEXT_FIX(1,0.51,0.55,1,'股現金流:',COLORYELLOW;DRAWTEXT_FIX(1,0.51,0.65,1,'股未分配:',COLORYELLOW;DRAWTEXT_FIX(1,0.51,0.75,1,'股公積金:',COLORYELLOW;DRAWNUMBER_FIX(1,0.57,0.15,1,市凈率),COLORWHITE;DRAWNUMBER_FIX(1,0.57,0.25,1,市銷率),COLORWHITE;DRAWNUMBER_FIX(1,0.57,0.35,1,每股收益季),COLORWHITE;DRAWNUMBER_FIX(1,0.57,0.45,1,每股收益年),COLORWHITE;DRAWNUMBER_FIX(1,0.57,0.55,1,每股現金流),COLORWHITE;DRAWNUMBER_FIX(1,0.57,0.65,1,每股未分配),COLORWHITE;DRAWNUMBER_FIX(1,0.57,0.75,1,每股公積金),COLORWHITE;X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;X3:=FINANCE(23)/FINANCE(10)*3.3;X4:=FINANCE(19)/FINANCE(15)*0.6;X5:=FINANCE(20)/FINANCE(15)*0.999;Z值:=X1+X2+X3+X4+X5;DRAWTEXT_FIX(1,0.85,0.01,1,'務預警:',COLORRED;DRAWTEXT_FIX(Z值<1.2,0.838,0.11,1,'●重 警●',COLORLIRED;DRAWTEXT_FIX( BETWEEN(Z值,1.2,2.6),0.838,0.11,1,'○輕 警○',COLOR0099FF;
    ?
    DRAWTEXT_FIX(Z值>2.6,0.838,0.11,1,'◎無 警◎',COLORLIGREEN;LC:=REF(CLOSE,1);WRSI:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;獲利籌碼:=CONST(WINNER(C)*100);SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));量能飽和:=(IF(SAT>1,1,SAT)*100);WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100;活躍:=(WRSI-WR10);活躍度比:=IF(活躍>=0,(活躍+100)/2,100-ABS((活躍-100)/2));DRAWTEXT_FIX(1,0.74,0.15,1,STRCAT(STRCAT('能飽和: 'CON2STR(量能飽和,2)),''),COLORYELLOW;DRAWTEXT_FIX(1,0.74,0.35,1,STRCAT(STRCAT('躍度比: 'CON2STR(活躍度比,2)),''),COLORYELLOW;DRAWTEXT_FIX(1,0.74,0.55,1,STRCAT(STRCAT('利籌碼: 'CON2STR(獲利籌碼,2)),''),COLORYELLOW;DRAWRECTREL(970,340,580,270,RGB(150,10,250));DRAWRECTREL(970,470,580,540,RGB(150,10,250));DRAWRECTREL(970,670,580,740,RGB(150,10,250));DRAWRECTREL(970,340,580+CONST(量能飽和*(970-580)/100),270,RGB(0,100,0));DRAWRECTREL(970,470,580+CONST(活躍度比*(970-580)/100),540,RGB(0,100,0));
    ?
    DRAWRECTREL(970,670,580+CONST(獲利籌碼*(970-580)/100),740,RGB(0,100,0));DRAWTEXT_FIX(1,0.96,0.01,1,'盤趨勢:',COLORRED;DRAWTEXT_FIX( CONST(INDEXC) >SAR(4,2,20),0.95,0.16,1,'∧∧∧',COLORRED;DRAWTEXT_FIX( CONST(INDEXC) >SAR(4,2,20),0.95,0.11,1,'∧∧∧',COLORRED;DRAWTEXT_FIX( CONST(INDEXC) <SAR(4,2,20),0.95,0.16,1,'∨∨∨',COLORGREEN;DRAWTEXT_FIX( CONST(INDEXC) <SAR(4,2,20),0.95,0.11,1,'∨∨∨',COLORGREEN;DRAWTEXT_FIX(1,0.87,0.85,1,'聯盟',COLORYELLOW;





    文件名:555.png
    ,其中涉及到一些基本面的數據,不知道如何提取,弄好之后是圖片這樣的,基本資料信息可以忽略,重點是圖片效果和算法不變化

    ?

    ?來源:程序化99

  • 文華技術人員: ?DRAWRECTREL是畫矩形函數
    文華中沒有替換函數,實際并不能改的,請您理解

    ?

    ?來源: www.946547.tw

  • 文華客服: ?可不可以不畫矩形,直接以三個名稱(量能飽和? 活躍度比? ?獲利籌碼 )百分比數字提供給我指標信息?

    ?

  • 網友回復: ? LC:=REF(CLOSE,1); WRSI:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100; 獲利籌碼:REFX1(WINNER(C)*100,10000); SAT:=(AVPRICE*V/C)/(HHV(AVPRICE*V,20)/HHV(C,20)); 量能飽和:(IF(SAT>1,1,SAT)*100); WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100; 活躍:=(WRSI-WR10); 活躍度比:IF(活躍>=0,(活躍+100)/2,100-ABS((活躍-100)/2));

    ?

  • 網友回復: ?謝謝,但是獲利籌碼好像沒有數字

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信號:cxh99cxh99  進行 有償收費 編寫!

怎么收費,代編流程等詳情請點擊閱讀!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
排列五千神机器人软件