您現在的位置:程序化交易>> 股票公式>> 通達信>> 通達信公式>>正文內容

看清主力指標公式源碼[通達信公式]

相關標簽: 通達信機構游資進場指標 、 通達信龍虎榜副圖指標 、 超級主力建倉指標公式 、 通達信主力資金指標 、 主力資金指標源碼有圖 、 主力游資大戶指標導入 、 通達信 知名游資 副圖 、 主力游資散戶副圖指標 、 通達信主力成交量指標 、 通達信知名游資指標公式 、 主力建倉完成指標源碼 、 主力資金游資資金指標 、

?

原理解析:


?

?來源:程序化99( www.946547.tw )

源碼:

?

V1:=(C*2+H+L)/4*10;
V2:=EMA(V1,13)-EMA(V1,34);
V3:=EMA(V2,5);
V4:=2*(V2-V3)*5.5;
莊家秘密撤: IF(V4<=0,V4,0),COLOR00FF00,LINETHICK2;
莊家秘密進: IF(V4>=0,V4,0),COLORFF00FF,LINETHICK2;
V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
V6:=EMA(3*V5-2*SMA(V5,18,1),5);
V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
V8:=(INDEXC*2+INDEXH+INDEXL)/4;
V9:=EMA(V8,13)-EMA(V8,34);
VA:=EMA(V9,3);
VB:=(V9-VA)/2;
大盤資金進場: IF(VB>=0,VB,0),COLORYELLOW,LINETHICK2;
大盤資金撤走: IF(VB<=0,VB,0),COLORBLUE,LINETHICK2;AA:=WINNER(CLOSE+CLOSE*15/100)*100;
BB:=WINNER(CLOSE+CLOSE*0/100)*100;
CC:=AA-BB;
DD:=(WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;
EE:=CC<3 AND DD<0.5;
A1:=DYNAINFO(6);
A2:=IF(LOW>A1,0,IF(HIGH<A1,1,(A1-LOW+0.01)/(HIGH-LOW+0.01)));
A3:=VOL/WINNER(LOW);
A4:=REF(HHV(CLOSE,120),1);
A5:=REF(LLV(CLOSE,120),1);
A6:=100*(CLOSE-A5)/(A4-A5);
A7:=A2>0 OR A2=1;
A8:=A7 AND A3/REF(A3,3)>=3 AND A6<80;
A9:=REF(A8,1) OR REF(A8,2) OR REF(A8,3) OR REF(A8,4);
A10:=A8 AND A9;
A11:=IF(FILTER(A8,3),5,0);
A12:=IF(FILTER(A10,3) OR EE,10,0);
資金進場日:IF(A11,8,0),LINETHICK0;
STICKLINE(A12,0,15,5,1),COLORFF00FF;
資金加倉日:IF(A12,88,0),LINETHICK0;
STICKLINE(A12,0,15,5,1),COLORFF00FF;STICKLINE(A11,0,5,1,0),COLORFFEE00;STICKLINE(A12,0,15,1,0),COLOR1020FF;
DRAWTEXT(A11,8,'資金進場');DRAWTEXT(A12,17,'資金加倉');
VAR1:=REF(LOW,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),13,1)*4;
VAR3:=EMA(VAR2,13);
VAR4:=LLV(LOW,34);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
主力進場:
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,7,1 ),COLORRED;
洗盤:IF(VAR5<REF(VAR5,1),VAR5,0),COLORGREEN,LINETHICK2;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2,1),COLORGREEN;VAR6:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR7:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR8:=VAR6<REF(VAR7,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(VAR8 AND COUNT(VAR8,30)=1,40,'有大資金進場跡象,關注!');

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  排列五千神机器人软件