您現在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文內容

北狼決殺指標公式源碼[大智慧公式]

相關標簽:

?

藍色持股,紅色賣出,個別地方買賣信號有些滯后,看黃線,向上彎頭背離時參考買入,見紅箭頭標注地方,破五日線先賣出。

?

?

原理解析:


?

?來源:程序化99( www.946547.tw )

源碼:

?

?


{北狼絕殺 新一代}
{參數 n 30 0 120}
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1) ;
D:=SMA(K,3,1);
買進:IF(D<25 AND CROSS(K,D) ,80,0),COLORMAGENTA,STICK;
賣出:IF(D>75 AND CROSS(D,K) ,80,0),COLORGREEN,STICK;
STICKLINE(K>D,K,D,2,0),COLORFFFF50;
STICKLINE(D>K,K,D,2,0),COLOR0000FF;
VAR1:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR2:=(CLOSE-MA(CLOSE,26))/MA(CLOSE,21)*100;
VAR3:=(CLOSE-MA(CLOSE,90))/MA(CLOSE,34)*100;
VAR4:=(VAR1+3*VAR2+9*VAR3)/13;
VAR5:=(100-ABS(VAR4));
VAR6:=ABS((COST(40)-CLOSE)/CLOSE*100);
VAR10:=LLV(LOW,10);
VAR13:=HHV(HIGH,25);
M:EMA((CLOSE-VAR10)/(VAR13-VAR10)*4,4)*25,COLORYELLOW,LINETHICK2;
RSV10:= (HHV(HIGH,11)-CLOSE)/(HHV(HIGH,11)-LLV(LOW,11))*100;
LWR1:SMA(RSV10,3,1),COLORRED,LINETHICK2;
LWR2:SMA(LWR1,3,1),COLORWHITE;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100;
很準:CROSS(RSI,11)*80,COLORRED;
DRAWTEXT(很準,79,'準'),COLOR66FFCC;
AA:=LLV(LOW,34);
BB:=HHV(HIGH,30);
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
絕谷:=(((DD-LLV(DD,21))/(HHV(DD,21)-LLV(DD,21)))*(4))*(25);
殺入:IF(CROSS(絕谷,90) AND (DD<40),70,0),COLORFFFF00;


{北狼㊣決殺 通達信}
{參數 N 0 120 30}
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1),COLORYELLOW;{http://cxh99.com} D:=SMA(K,3,1),COLORWHITE,;
買進:IF(D<25 AND CROSS(K,D) ,80,0),COLORMAGENTA,STICK;
賣出:IF(D>75 AND CROSS(D,K) ,80,0),COLORGREEN,STICK;
STICKLINE(K>D,K,D,2,0),COLORFFFF50;
STICKLINE(D>K,K,D,2,0),COLOR0000FF;
VAR1:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR2:=(CLOSE-MA(CLOSE,26))/MA(CLOSE,21)*100;
VAR3:=(CLOSE-MA(CLOSE,90))/MA(CLOSE,34)*100;
VAR4:=(VAR1+3*VAR2+9*VAR3)/13;
VAR5:=(100-ABS(VAR4));
VAR6:=ABS((COST(40)-CLOSE)/CLOSE*100);
VAR10:=LLV(LOW,10);
VAR13:=HHV(HIGH,25);
M:EMA((CLOSE-VAR10)/(VAR13-VAR10)*4,4)*25,COLORYELLOW,LINETHICK2;
RSV10:= (HHV(HIGH,11)-CLOSE)/(HHV(HIGH,11)-LLV(LOW,11))*100;
LWR1:SMA(RSV10,3,1),COLORRED,LINETHICK2;
LWR2:SMA(LWR1,3,1),COLORWHITE;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100;
很準:CROSS(RSI,11)*80,COLORRED;
DRAWTEXT(很準,79,'準'),COLOR66FFCC;
AA:=LLV(LOW,34);
BB:=HHV(HIGH,30);
DD:=(EMA(((CLOSE-AA)/(BB-AA))*(4),4))*(25);
絕谷:=(((DD-LLV(DD,21))/(HHV(DD,21)-LLV(DD,21)))*(4))*(25);
殺入:IF(CROSS(絕谷,90) AND (DD<40),70,0),COLORFFFF00;<!--++ plugin_code qcomic begin-->

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  排列五千神机器人软件