您現在的位置:程序化交易>> 股票公式>> 通達信>> 通達信公式>>正文內容

買賣出擊指標公式源碼[通達信公式]

相關標簽: 多空資金線指標源碼 、 擒妖股主圖指標源碼 、 通達信趨勢主圖指標 、 通達信主圖買賣指標 、 絕密分時主圖買賣指標 、 精準買賣主圖指標公式 、 簡單趨勢買賣指標公式 、 通達信趨勢買賣指標公式 、 均線買賣提醒主圖指標 、 精準買賣指標公式源碼 、 均線買賣主圖指標源碼 、 有沒有賣源碼的平臺 、

?

?

原理解析:


?

?來源:程序化99( www.946547.tw )

源碼:

?

?

N:=20;
N1:=7;
N2:=69;
T1:=IF((DATE<=1341231),1,0);
M3:=EMA(CLOSE,3);
M8:EMA(CLOSE,8),COLOR008000;
M13:EMA(M8,13),COLOR0000FF;
M62:EMA(M8,55),COLORF0F000;
VAR1:=EMA(M13,62);
M81:EMA(M62,81),COLOR00FFFF;
M144:EMA(VAR1,144),LINETHICK2,COLOR0000FF;
M250:EMA(VAR1,250),POINTDOT,LINETHICK2,COLORF00FF0;
VAR2:=(CLOSE+HIGH+LOW)/(3);
VAR3:=(EMA(VAR2,10))*(T1);
VAR4:=(REF(VAR3,1))*(T1);
STICKLINE((VAR3>VAR4),VAR3,VAR4,4,0),COLOR00FFFF;
STICKLINE((VAR3<VAR4),VAR3,VAR4,4,0),COLORFF0000;
VAR5:=((REF(HIGH,1)+REF(LOW,1))/(2))*(T1);
VAR6:=MA(CLOSE,N)+((2)*(STD(CLOSE,N)))*(T1);
DRAWTEXT(CROSS(VAR3,VAR4),(VAR3)*(0.98),''),COLOR00FFFF;
DRAWTEXT(CROSS(VAR5,VAR6),(HIGH)*(1.04),'↓賣'),COLOR008000;
VAR7:=REF(CLOSE,1);
VAR8:=((SMA(MAX(CLOSE-VAR7,0),N1,1))/(SMA(ABS(CLOSE-VAR7),N1,1)))*(100);
VAR9:=CROSS(N2,VAR8);
VARA:=(FILTER(VAR9,4))*(T1);
DRAWTEXT(VARA,(HIGH)*(1.04),'↓賣'),COLORFFFFFF;
VARB:=((2)*(CLOSE)+HIGH+LOW)/(4);
VARC:=LLV(LOW,34);
VARD:=HHV(HIGH,34);
VARE:=(EMA(((VARB-VAR1)/(VAR5-VAR1))*(100),7))*(T1);
VARF:=(EMA((0.667)*(REF(VARE,1))+(0.333)*(VARE),5))*(T1);
DRAWTEXT(IF(((COUNT((CLOSE<REF(CLOSE,1)),8))/(8)>0.6) AND (VOL>=(1.5)*(MA(VOL,5))) AND COUNT((VARE>=VARF),3) AND (REF(LOW,1)=LLV(LOW,120)),1,0),LOW,'●買進'),COLORFF00FF;
DRAWTEXT(IF(((COUNT((CLOSE<REF(CLOSE,1)),13))/(13)>0.6) AND COUNT((VARE>VARF),6) AND (REF(LOW,5)=LLV(LOW,120)) AND REF((CLOSE>=OPEN),4) AND REF((CLOSE>OPEN),3) AND REF((CLOSE>OPEN),2) AND REF((OPEN>CLOSE),1) AND (OPEN>REF(CLOSE,1)),1,0),LOW,'●買進'),COLOR00FFFF;
VAR10:=(MA(CLOSE,80)-(MA(CLOSE,10))/(3))*(T1);
DRAWTEXT(IF((CLOSE<VAR10) AND ((VOL)/(240)>(MA(VOL,5))/(240)) AND (CLOSE>(REF(CLOSE,1))*(1.08)) AND (CLOSE<(MA(CLOSE,13))*(1.3)),1,0),LOW,'●抄底'),COLOR0000FF;

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  排列五千神机器人软件