您現在的位置:程序化交易>> 股票公式>> 通達信>> 通達信公式>>正文內容

投資線指標公式源碼、副圖[通達信公式]

相關標簽: 主力持倉指標源碼公式 、 主力籌碼主升指標公式 、 通達信期貨副圖指標源碼 、 level2主力持倉線指標 、 籌碼成本主力線主圖 、

?

該指標和傳統的使用方法大致相同分為危險區域和安全區域,80以上為危險區25以下安全區,其次還有長期、中期和短期線靈活運用當中期線處于底部上翹時短線可以參與,當長期線和中期線都處于底部上翹時中期可以參與。指標中的短期線直供參考變化太快不適宜新手操作。其次判官把一品老師的量價指標搬到了該指標里面既綠色粗線,在使用時注意綠色線的走勢。綠色線與中期線背離時不宜買進{長期線}

?

?

原理解析:


?

?來源:程序化99( www.946547.tw )

源碼:

?

?

?


A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19),COLORRED;
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4),LINETHICK2;
長期線:A+100,COLORRED;
短期線:B+100,COLOR888888,COLOR7C7C7C;
中期線:D+100,COLORYELLOW,LINETHICK2;
量價關系:EMA(SUM((CLOSE-OPEN)/(HIGH-LOW)*VOL,21)/10000,5),COLORGREEN,LINETHICK2;
80,COLOR996699;
20,COLORGREEN;
10,COLORCC6633,LINETHICK2;
90,COLOR9966FF,LINETHICK2;
見頂:=((REF(中期線,1)>85 AND REF(短期線,1)>85 AND REF(長期線,1)>65) AND CROSS(長期線,短期線)) ,COLORGREEN;
頂部區域:(中期線<REF(中期線,1) AND REF(中期線,1)>80) AND (REF(短期線,1)>95 OR REF(短期線,2)>95 ) AND 長期線>60 AND 短期線<83.5
AND 短期線<中期線 AND 短期線<長期線+4,COLORGREEN;
頂部:=FILTER(頂部區域,4);
STICKLINE( {見頂 OR} 頂部,99,103,20,1 ),COLORRED,LINETHICK2;底部區域:(長期線<12 AND 中期線<8 AND (短期線<7.2 OR REF(短期線,1)<5) AND (中期線>REF(中期線,1) OR 短期線>REF(短期線,1)))
OR (長期線<8 AND 中期線<7 AND 短期線<15 AND 短期線>REF(短期線,1)) OR (長期線<10 AND 中期線<7 AND 短期線<1) ,COLORGREEN;STICKLINE( 底部區域,-4,0,22,0 ),COLORGREEN;
低位金叉:50*(長期線<15 AND REF(長期線,1)<15 AND 中期線<18 AND 短期線>REF(短期線,1) AND CROSS(短期線,長期線) AND 短期線>中期線
AND (REF(短期線,1)<5 OR REF(短期線,2)<5 ) AND (中期線>=長期線 OR REF( 短期線,1)<1 )),COLORRED;
STICKLINE( 低位金叉,0,5,11,0 ),COLORRED;

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  排列五千神机器人软件