您現在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文內容

神奇均線_立體k線_財務指標公式[大智慧公式]

相關標簽: 封成比計算指標公式 、 通達信公式源代碼大全 、 通達信普通k線指標源碼 、 通達信顏色數字代碼 、 第一最牛指標通達信 、 通達信顏色函數大全 、 通達信顏色源碼 、

?

原理解析:


?

?來源:程序化99( www.946547.tw )

源碼:

?

Var1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A1: (EMA(Var1,3)+EMA(Var1,6)+EMA(Var1,12)+EMA(Var1,24))/4;
A2: EMA(A1,2);
A3: EMA(A2,2);
A4: EMA(A3,2);
A5: EMA(A4,2);
A6: EMA(A5,2);
A7: EMA(A6,2);
A8: EMA(Var1,2.78)*1.028;
A9: MA(OPEN,3.2)*1.028;
安全線: EMA(CLOSE,55), CIRCLEDOT;
{財務原碼}
蕕利比例:WINNER(c )*100,linethick0, colorFF00FF,precis2;
市盈率:DYNAINFO(39),linethick0,COLORYELLOW,precis2 ;
市凈率:DYNAINFO(58),linethick0,colorFF00FF ,precis2;
流通股:=FINANCE2(37);
每股收益:=FINANCE2(3);
每股公積:=FINANCE2(7);
未分配利潤:=FINANCE2(8);
每股凈資產:=FINANCE2(4);
凈資產收益率:=FINANCE2(5);
總股本:=FINANCE2(35) ;
股東權益比:=FINANCE2(9);
限售A股:=FINANCE2(41);
流通B股:=FINANCE2(38);
流通H股:=FINANCE2(39);
DRAWTEXTABS(25,00,'總股本: '+NUMTOSTRN(總股本,2)+' 萬股'),colorFF00FF;
DRAWTEXTABS(200,00,'流通A股: '+NUMTOSTRN(流通股,2)+' 萬股'),Color00FFFF;
DRAWTEXTABS(360,00,'流通B股: '+NUMTOSTRN(流通B股,2)+' 萬股'),colorFF00FF;
DRAWTEXTABS(25,15,'限售A股: '+NUMTOSTRN(限售A股,2)+' 萬股'),colorFF00FF;
DRAWTEXTABS(200,15,'流通H股: '+NUMTOSTRN(流通H股,2)+' 萬股'),Color00FFFF;
DRAWTEXTABS(25,30,'每股收益: '+NUMTOSTRN(每股收益,2)+' 元'),colorFF00FF;
DRAWTEXTABS(200,30,'每股凈資產: '+NUMTOSTRN(每股凈資產,2)+' 元'),Color00FFFF;
DRAWTEXTABS(25,45,'凈資產收益率: '+NUMTOSTRN(凈資產收益率,2)+' %'),colorFF00FF;
DRAWTEXTABS(200,45,'未分配利潤: '+NUMTOSTRN(未分配利潤,2)+' 元'),Color00FFFF;
DRAWTEXTABS(25,60,'每股公積: '+NUMTOSTRN(每股公積,2)+' 元'),colorFF00FF;
DRAWTEXTABS(200,60,'股東權益比: '+NUMTOSTRN(股東權益比,2)+' %'),Color00FFFF;
DRAWTEXTABS(25,75,'機構評級:'+Extrastring('評級')),colorFF00FF;
DRAWTEXTABS(25,90,'所屬板塊:'+BKNAME),colorFF00FF;

STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0 ),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5 ,0 ),COLOR0000FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLORff7700;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLORff9900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLORffbb00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLORffcc00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORffdd00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLORffee00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLORffFF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLOR000055;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR000077;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000bb;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000dd;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000ff;
var9Q:=c= hhv(c,4)and (ref(c,1)>=ref(c,2) or ref(c,1)>=ref(c,3)) or ref(c,1)=hhv(c,4) and close>=ref(c,2) or ref(c,2)=hhv(c,4) and ref(c,3)=llv(c,4) and c>=ref(c,1) or ref(c,3)=hhv(c,4) and c>=ref(c,1) and c>=ref(c,2);
stickline(var9Q,c,(o+c)/2,7,0),color000055;
stickline(var9Q,c,(o+c)/2,6,0),color000066;
stickline(var9Q,c,(o+c)/2,5,0),color000077;
stickline(var9Q,c,(o+c)/2,4,0),color000099;
stickline(var9Q,c,(o+c)/2,3,0),color0000bb;
stickline(var9Q,c,(o+c)/2,2,0),color0000dd;
stickline(var9Q,c,(o+c)/2,1,0),color0000ff;
varaQ:=c=hhv(c,4) and ref(c,1)=llv(c,4);
stickline(varaQ,c,(o+c)/2,7,0),colorff11ff;
stickline(varaQ,c,(o+c)/2,6,0),colorff33ff;
stickline(varaQ,c,(o+c)/2,5,0),colorff55ff;
stickline(varaQ,c,(o+c)/2,4,0),colorff77ff;
stickline(varaQ,c,(o+c)/2,3,0),colorff99ff;
stickline(varaQ,c,(o+c)/2,2,0),colorffbbff;
stickline(varaQ,c,(o+c)/2,1,0),colorffddff;
varbQ:=c=llv(c,4) and (ref(c,1)<ref(c,2) or ref(c,1)<ref(c,3)) or ref(c,1)=llv(c,4) and c<ref(c,2) or ref(c,2)=llv(c,4) and ref(c,1)<>hhv(c,4) and c<ref(c,1) or ref(c,3)=llv(c,4) and c<ref(c,1) and c<ref(c,2);
stickline(varbQ,c,(o+c)/2,7,0),color333333;
stickline(varbQ,c,(o+c)/2,6,0),color555555;
stickline(varbQ,c,(o+c)/2,5,0),color777777;
stickline(varbQ,c,(o+c)/2,4,0),color999999;
stickline(varbQ,c,(o+c)/2,3,0),colorbbbbbb;
stickline(varbQ,c,(o+c)/2,2,0),colordddddd;
stickline(varbQ,c,(o+c)/2,1,0),colorffffff;
varcQ:=ref(c,1)=llv(c,4) and c>=ref(c,2) or ref(c,2)=llv(c,4) and ref(c,1)<=ref(c,3) and ref(c,2)<ref(c,4) and c>=ref(c,1);
stickline(varcQ,o,(o+c)/2,7,0),color003300;
stickline(varcQ,o,(o+c)/2,6,0),color005500;
stickline(varcQ,o,(o+c)/2,5,0),color007700;
stickline(varcQ,o,(o+c)/2,4,0),color009900;
stickline(varcQ,o,(o+c)/2,3,0),color00bb00;
stickline(varcQ,o,(o+c)/2,2,0),color00dd00;
stickline(varcQ,o,(o+c)/2,1,0),color00ff00;
vardQ:=ref(c,1)=hhv(c,4) and c<ref(c,2) or (ref(c,2)=hhv(c,4) and ref(c,1)>ref(c,3) or ref(c,3)=hhv(c,4) and ref(c,1)>ref(c,2)) and ref(c,2)>=ref(c,4) and c<ref(c,1);
stickline(vardQ,o,(o+c)/2,7,0),colorff1100;
stickline(vardQ,o,(o+c)/2,6,0),colorff3300;
stickline(vardQ,o,(o+c)/2,5,0),colorff5500;
stickline(vardQ,o,(o+c)/2,4,0),colorff7700;
stickline(vardQ,o,(o+c)/2,3,0),colorff9900;
stickline(vardQ,o,(o+c)/2,2,0),colorffbb00;
stickline(vardQ,o,(o+c)/2,1,0),colorffdd00;
{程序化交易 www.946547.tw }

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  排列五千神机器人软件