您現在的位置:程序化交易>> 期貨公式>> 博易大師>> 博易大師知識>>正文內容

送大家個指標 [博易POBO]

咨詢內容:

送大家個指標

?博易大師主圖
P1:=1;
P3:=3;
P5:=5;
P8:=8;
P13:=13;
P21:=21;
P34:=34;
P55:=55;
P89:=89;
P144:=144;
P233:=233;
P377:=377;
ASA1:=REF(H,P1)=HHV(H,2*P1+1);
BSB1:=FILTER(ASA1,P1);
CSC1:=BACKSET(BSB1,P1+1);
DSD1:=CROSS(CSC1,0.5);
DRAWTEXT(DSD1,H*1.001,'▼'),COLOR00FF00;
ASA2:=REF(L,P1)=LLV(L,2*P1+1);
BSB2:=FILTER(ASA2,P1);
CSC2:=BACKSET(BSB2,P1+1);
DSD2:=CROSS(CSC2,0.5);
DRAWTEXT(DSD2,L*0.999,'▲'),COLOR0000FF;

A1:=REF(H,P3)=HHV(H,2*P3+1);
B01:=FILTER(A1,P3);
C1:=BACKSET(B01,P3+1);
D1:=CROSS(C1,0.5);
DRAWTEXT(D1,H,'空空'),COLORGREEN;
A2:=REF(L,P3)=LLV(L,2*P3+1);
B2:=FILTER(A2,P3);
C2:=BACKSET(B2,P3+1);
D2:=CROSS(C2,0.5);
DRAWTEXT(D2,L,'多多'),COLOR0000FF;

AA1:=REF(H,P5)=HHV(H,2*P5+1);
BB1:=FILTER(AA1,P5);
CC1:=BACKSET(BB1,P5+1);
DD1:=CROSS(CC1,0.5);
DRAWTEXT(DD1,H,'空空空'),COLORGREEN;
AA2:=REF(L,P5)=LLV(L,2*P5+1);
BB2:=FILTER(AA2,P5);
CC2:=BACKSET(BB2,P5+1);
DD2:=CROSS(CC2,0.5);
DRAWTEXT(DD2,L,'多多多'),COLOR0000FF;

AAA1:=REF(H,P8)=HHV(H,2*P8+1);
BBB1:=FILTER(AAA1,P8);
CCC1:=BACKSET(BBB1,P8+1);
DDD1:=CROSS(CCC1,0.5);
DRAWTEXT(DDD1,H,'空空空空'),COLORGREEN;
AAA2:=REF(L,P8)=LLV(L,2*P8+1);
BBB2:=FILTER(AAA2,P8);
CCC2:=BACKSET(BBB2,P8+1);
DDD2:=CROSS(CCC2,0.5);
DRAWTEXT(DDD2,L,'多多多多'),COLOR0000FF;

AAAA1:=REF(H,P13)=HHV(H,2*P13+1);
BBBB1:=FILTER(AAAA1,P13);
CCCC1:=BACKSET(BBBB1,P13+1);
DDDD1:=CROSS(CCCC1,0.5);
DRAWTEXT(DDDD1,H,'空空空空空'),COLORGREEN;
AAAA2:=REF(L,P13)=LLV(L,2*P13+1);
BBBB2:=FILTER(AAAA2,P13);
CCCC2:=BACKSET(BBBB2,P13+1);
DDDD2:=CROSS(CCCC2,0.5);
DRAWTEXT(DDDD2,L,'多多多多多'),COLOR0000FF;

AJA1:=REF(H,P21)=HHV(H,2*P21+1);
BJB1:=FILTER(AJA1,P21);
CJC1:=BACKSET(BJB1,P21+1);
DJD1:=CROSS(CJC1,0.5);
DRAWTEXT(DJD1,H,'空空空空空空'),COLORGREEN;
AJA2:=REF(L,P21)=LLV(L,2*P21+1);
BJB2:=FILTER(AJA2,P21);
CJC2:=BACKSET(BJB2,P21+1);
DJD2:=CROSS(CJC2,0.5);
DRAWTEXT(DJD2,L,'多多多多多多'),COLOR0000FF;

AGA1:=REF(H,P34)=HHV(H,2*P34+1);
BGB1:=FILTER(AGA1,P34);
CGC1:=BACKSET(BGB1,P34+1);
DGD1:=CROSS(CGC1,0.5);
DRAWTEXT(DGD1,H,'空空空空空空空'),COLORGREEN;
AGA2:=REF(L,P34)=LLV(L,2*P34+1);
BGB2:=FILTER(AGA2,P34);
CGC2:=BACKSET(BGB2,P34+1);
DGD2:=CROSS(CGC2,0.5);
DRAWTEXT(DGD2,L,'多多多多多多多'),COLOR0000FF;

ARA1:=REF(H,P55)=HHV(H,2*P55+1);
BRB1:=FILTER(ARA1,P55);
CRC1:=BACKSET(BRB1,P55+1);
DRD1:=CROSS(CRC1,0.5);
DRAWTEXT(DRD1,H,'空空空空空空空空'),COLORGREEN;
ARA2:=REF(L,P55)=LLV(L,2*P55+1);
BRB2:=FILTER(ARA2,P55);
CRC2:=BACKSET(BRB2,P55+1);
DRD2:=CROSS(CRC2,0.5);
DRAWTEXT(DRD2,L,'多多多多多多多多'),COLOR0000FF;

AQA1:=REF(H,P89)=HHV(H,2*P89+1);
BQB1:=FILTER(AQA1,P89);
CQC1:=BACKSET(BQB1,P89+1);
DQD1:=CROSS(CQC1,0.5);
DRAWTEXT(DQD1,H,'空空空空空空空空空'),COLORGREEN;
AQA2:=REF(L,P89)=LLV(L,2*P89+1);
BQB2:=FILTER(AQA2,P89);
CQC2:=BACKSET(BQB2,P89+1);
DQD2:=CROSS(CQC2,0.5);
DRAWTEXT(DQD2,L,'多多多多多多多多多'),COLOR0000FF;

AZA1:=REF(H,P144)=HHV(H,2*P144+1);
BZB1:=FILTER(AZA1,P144);
CZC1:=BACKSET(BZB1,P144+1);
DZD1:=CROSS(CZC1,0.5);
DRAWTEXT(DZD1,H,'空空空空空空空空空空'),COLORGREEN;
AZA2:=REF(L,P144)=LLV(L,2*P144+1);
BZB2:=FILTER(AZA2,P144);
CZC2:=BACKSET(BZB2,P144+1);
DZD2:=CROSS(CZC2,0.5);
DRAWTEXT(DZD2,L,'多多多多多多多多多多'),COLORFFFFFF;

AWA1:=REF(H,P233)=HHV(H,2*P233+1);
BWB1:=FILTER(AWA1,P233);
CWC1:=BACKSET(BWB1,P233+1);
DWD1:=CROSS(CWC1,0.5);
DRAWTEXT(DWD1,H,'空空空空空空空空空空空'),COLORFF0000;
AWA2:=REF(L,P233)=LLV(L,2*P233+1);
BWB2:=FILTER(AWA2,P233);
CWC2:=BACKSET(BWB2,P233+1);
DWD2:=CROSS(CWC2,0.5);
DRAWTEXT(DWD2,L,'多多多多多多多多多多多'),COLORFFFFFF;


AXA1:=REF(H,P377)=HHV(H,2*P377+1);
BXB1:=FILTER(AXA1,P377);
CXC1:=BACKSET(BXB1,P377+1);
DXD1:=CROSS(CXC1,0.5);
DRAWTEXT(DXD1,H,'空空空空空空空空空空空空'),COLORGREEN;
AXA2:=REF(L,P377)=LLV(L,2*P377+1);
BXB2:=FILTER(AXA2,P377);
CXC2:=BACKSET(BXB2,P377+1);
DXD2:=CROSS(CXC2,0.5);
DRAWTEXT(DXD2,L,'多多多多多多多多多多多多'),COLOR0000FF;
?
?
?
第二個指標
博易大師附圖
?

?
第一步創建個指標名字(J多空)
?
N5:=1;
WH5:=HHV(HIGH,N5);
WL5:=LLV(LOW,N5);
HH5:=BARSLAST((WH5>REF(WH5,1)));
LL5:=BARSLAST((WL5<REF(WL5,1)));
WA5:=IF((HH5 < LL5),1,IF((HH5 > LL5),-1,0));
IF(WA5>=0,WL5,WH5),COLORYELLOW;
DRAWTEXT(CROSS(HH5,LL5),WH5,'開空');
DRAWTEXT(CROSS(LL5,HH5),WL5,'開多');
?
第二步
?
J1分鐘:=STKINDI(',1,'J多空');
J3分鐘:=STKINDI(',13,'J多空');
J5分鐘:=STKINDI(',2,'J多空');
J15分鐘:=STKINDI(',3,'J多空');
J半小時:=STKINDI(',4,'J多空');
時:=STKINDI(',5,'J多空');
兩小時線:=STKINDI(',15,'J多空');
四小時線:=STKINDI(',16,'J多空');
日:=STKINDI(',6,'J多空');
周:=STKINDI(',7,'J多空');
月:=STKINDI(',8,'J多空');
季:=STKINDI(',12,'J多空');
年:=STKINDI(',9,'J多空');
Y3:=CURRENTTIME-REF(REF(YEAR,1),1);
Y4:=YEAR-REF(REF(CURRENTTIME,1),1);
A:=CURRENTTIME-REF(YEAR,1);
B:=YEAR-REF(CURRENTTIME,1);
Y1:=MAX(A,B,Y3,Y4) ;
GT1:=ZIG(J1分鐘,1),COLORYELLOW,LINETHICK1;
GT2:=ZIG(J3分鐘,1),COLORYELLOW,LINETHICK1;
GT3:=ZIG(J5分鐘,1),COLORYELLOW,LINETHICK1;
GT4:=ZIG(J15分鐘,1),COLORYELLOW,LINETHICK1;
GT5:=ZIG(J半小時,1),COLORYELLOW,LINETHICK1;
GT6:=ZIG(時,1),COLORYELLOW,LINETHICK1;
GT7:=ZIG(兩小時線,1),COLORYELLOW,LINETHICK1;
GT8:=ZIG(四小時線,1),COLORYELLOW,LINETHICK1;
GT9:=ZIG(日,1),COLORYELLOW,LINETHICK1;
GT10:=ZIG(周,1),COLORYELLOW,LINETHICK1;
GT11:=ZIG(月,1),COLORYELLOW,LINETHICK1;
GT12:=ZIG(季,1),COLORYELLOW,LINETHICK1;
GT13:=ZIG(年,1),COLORYELLOW,LINETHICK1;

QR1:=BARSLAST(CROSS(MA(GT1,1),MA(GT1,2))),COLOR00A600;
QB1:=BARSLAST(CROSS(MA(GT1,2),MA(GT1,1))),COLOR0000FF;
HM1:QR1-QB1,COLOR00D900,LINETHICK1;
HN1:QB1-QR1,COLOR0000FF,LINETHICK1;
QR2:=BARSLAST(CROSS(MA(GT2,1),MA(GT2,2))),COLOR00A600;
QB2:=BARSLAST(CROSS(MA(GT2,2),MA(GT2,1))),COLOR0000FF;
HM2:QR2-QB2,COLOR00D900,LINETHICK1;
HN2:QB2-QR2,COLOR0000FF,LINETHICK1;
QR3:=BARSLAST(CROSS(MA(GT3,1),MA(GT3,2))),COLOR00A600;
QB3:=BARSLAST(CROSS(MA(GT3,2),MA(GT3,1))),COLOR0000FF;
HM3:QR3-QB3,COLOR00D900,LINETHICK1;
HN3:QB3-QR3,COLOR0000FF,LINETHICK1;
QR4:=BARSLAST(CROSS(MA(GT4,1),MA(GT4,2))),COLOR00A600;
QB4:=BARSLAST(CROSS(MA(GT4,2),MA(GT4,1))),COLOR0000FF;
HM4:QR4-QB4,COLOR00D900,LINETHICK1;
HN4:QB4-QR4,COLOR0000FF,LINETHICK1;
QR5:=BARSLAST(CROSS(MA(GT5,1),MA(GT5,2))),COLOR00A600;
QB5:=BARSLAST(CROSS(MA(GT5,2),MA(GT5,1))),COLOR0000FF;
HM5:QR5-QB5,COLOR00D900,LINETHICK1;
HN5:QB5-QR5,COLOR0000FF,LINETHICK1;
QR6:=BARSLAST(CROSS(MA(GT6,1),MA(GT6,2))),COLOR00A600;
QB6:=BARSLAST(CROSS(MA(GT6,2),MA(GT6,1))),COLOR0000FF;
HM6:QR6-QB6,COLOR00D900,LINETHICK1;
HN6:QB6-QR6,COLOR0000FF,LINETHICK1;
QR7:=BARSLAST(CROSS(MA(GT7,1),MA(GT7,2))),COLOR00A600;
QB7:=BARSLAST(CROSS(MA(GT7,2),MA(GT7,1))),COLOR0000FF;
HM7:QR7-QB7,COLOR00D900,LINETHICK1;
HN7:QB7-QR7,COLOR0000FF,LINETHICK1;
QR8:=BARSLAST(CROSS(MA(GT8,1),MA(GT8,2))),COLOR00A600;
QB8:=BARSLAST(CROSS(MA(GT8,2),MA(GT8,1))),COLOR0000FF;
HM8:QR8-QB8,COLOR00D900,LINETHICK1;
HN8:QB8-QR8,COLOR0000FF,LINETHICK1;
QR9:=BARSLAST(CROSS(MA(GT9,1),MA(GT9,2))),COLOR00A600;
QB9:=BARSLAST(CROSS(MA(GT9,2),MA(GT9,1))),COLOR0000FF;
HM9:QR9-QB9,COLOR00D900,LINETHICK1;
HN9:QB9-QR9,COLOR0000FF,LINETHICK1;
QR10:=BARSLAST(CROSS(MA(GT10,1),MA(GT10,2))),COLOR00A600;
QB10:=BARSLAST(CROSS(MA(GT10,2),MA(GT10,1))),COLOR0000FF;
HM10:QR10-QB10,COLOR00D900,LINETHICK1;
HN10:QB10-QR10,COLOR0000FF,LINETHICK1;
QR11:=BARSLAST(CROSS(MA(GT11,1),MA(GT11,2))),COLOR00A600;
QB11:=BARSLAST(CROSS(MA(GT11,2),MA(GT11,1))),COLOR0000FF;
HM11:QR11-QB11,COLOR00D900,LINETHICK1;
HN11:QB11-QR11,COLOR0000FF,LINETHICK1;
QR12:=BARSLAST(CROSS(MA(GT12,1),MA(GT12,2))),COLOR00A600;
QB12:=BARSLAST(CROSS(MA(GT12,2),MA(GT12,1))),COLOR0000FF;
HM12:QR12-QB12,COLOR00D900,LINETHICK1;
HN12:QB12-QR12,COLOR0000FF,LINETHICK1;
QR13:=BARSLAST(CROSS(MA(GT13,1),MA(GT13,2))),COLOR00A600;
QB13:=BARSLAST(CROSS(MA(GT13,2),MA(GT13,1))),COLOR0000FF;
HM13:QR13-QB13,COLOR00D900,LINETHICK1;
HN13:QB13-QR13,COLOR0000FF,LINETHICK1;
?
?
? _XPQ3XH8TDU7(DS16_VWLP.pngT80)}5(B{XA`T0Q(0%AN~D.png<!-- 咨詢內容:

附件 :

-->

?

?來源:程序化99網( www.946547.tw )

博易技術人員: 副圖指標不能通過,提示STKINDI函數個數缺少 來源 程序化久久網

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信號:cxh99cxh99  進行 有償收費 編寫!

怎么收費,代編流程等詳情請點擊閱讀!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
排列五千神机器人软件