您現在的位置:程序化交易>> 期貨公式>> 博易大師>> 博易大師知識>>正文內容

請老師修改成博易大師源碼這是文華的指標 [博易POBO]

咨詢內容:

請老師修改成博易大師源碼這是文華的指標

//EMA12:EMA(CLOSE,SHORT),NODRAW;
//EMA26:EMA(CLOSE,LONG),NODRAW;
DIFF:=EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
均線差值:DIFF;
DEA: =EMA(DIFF,M);
差值的均值:DEA;
MACD:=2*(DIFF-DEA);
//MACDAVG:=MA(MACD,N);
//MACDAVGS:MACDAVG;
2*(DIFF-DEA),COLORSTICK;
POLYLINE((MOD(BARPOS,N1)=0 || ISLASTBAR),MACD,COLORGRAY);
DRAWTEXT((MOD(BARPOS,N1)=0 || ISLASTBAR) && MACD>REF(MACD,N1) ,MACD,'漲'),COLORRED;
DRAWTEXT((MOD(BARPOS,N1)=0 || ISLASTBAR) && MACD<REF(MACD,N1) ,MACD,'跌'),COLORGREEN;
DRAWTEXT((MOD(BARPOS,N1)=0 || ISLASTBAR) && MACD=REF(MACD,N1) ,MACD,'平'),COLORGRAY;
//POLYLINE(BARSLAST(MOD(BARPOS,N1)=0),MACD,COLORRED);
//POLYLINE(MOD(BARPOS,N1)=0 && MACD<REF(MACD,N1),MACD,COLORGREEN);
//POLYLINE(MOD(BARPOS,N1) =0&& MACD=REF(MACD,N1),MACD,COLORYELLOW);
//DRAWLINE(MACD>0,MACD, MACD<=0,REF(MACD,1),COLORRED);
//MOD(MINUTE,10)
DRAWICON(CROSS(DIFF,DEA),DIFF,1);
DRAWICON(CROSS(DEA,DIFF),DEA,2);

?

?來源:程序化99網( www.946547.tw )

博易技術人員: //EMA12:EMA(CLOSE,SHORT),NODRAW;
//EMA26:EMA(CLOSE,LONG),NODRAW;
N1:=10;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
均線差值:DIFF;
DEA:=EMA(DIFF,9);
差值的均值:DEA;
MACD:=2*(DIFF-DEA);
//MACDAVG:=MA(MACD,N);
//MACDAVGS:MACDAVG;
2*(DIFF-DEA),COLORSTICK;
POLYLINE((MOD(BARPOS,N1)=0 || ISLASTBAR),MACD),COLORGRAY;
DRAWTEXT((MOD(BARPOS,N1)=0 || ISLASTBAR) && MACD>REF(MACD,N1) ,MACD,'漲'),COLORRED;
DRAWTEXT((MOD(BARPOS,N1)=0 || ISLASTBAR) && MACD<REF(MACD,N1) ,MACD,'跌'),COLORGREEN;
DRAWTEXT((MOD(BARPOS,N1)=0 || ISLASTBAR) && MACD=REF(MACD,N1) ,MACD,'平'),COLORGRAY;
//POLYLINE(BARSLAST(MOD(BARPOS,N1)=0),MACD,COLORRED);
//POLYLINE(MOD(BARPOS,N1)=0 && MACD<REF(MACD,N1),MACD,COLORGREEN);
//POLYLINE(MOD(BARPOS,N1) =0&& MACD=REF(MACD,N1),MACD,COLORYELLOW);
//DRAWLINE(MACD>0,MACD, MACD<=0,REF(MACD,1),COLORRED);
//MOD(MINUTE,10)
DRAWICON(CROSS(DIFF,DEA),DIFF,1);
DRAWICON(CROSS(DEA,DIFF),DEA,2); 老師跟文華的還是郵差距但是謝謝 來源 程序化久久網

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信號:cxh99cxh99  進行 有償收費 編寫!

怎么收費,代編流程等詳情請點擊閱讀!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
排列五千神机器人软件