您現在的位置:程序化交易>> 股票公式>> 通達信>> 通達信公式>>正文內容

三線做多,自創很好的指標源碼[通達信公式]

相關標簽: 通達信三線翻多公式 、 三線翻多指標可靠嗎 、 張宇明漲跌三線指標 、 張宇明股神指標源碼 、 張宇明趨勢線指標源碼 、 三線翻多是哪三線 、 股神張宇明三線指標 、 乾坤三線指標怎么看 、 三線翻多指標源碼 、 通達信選股指標公式副圖 、 漲跌三線軟件 軟件官方 、 通達信三線合一指標 、

?

?

?

原理解析:


?

?來源:程序化99( www.946547.tw )

源碼:

?

?

?

LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100;
買3:=CROSS(RSI1,RSI2) AND CROSS("RSI.RSI1",50);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
買1:=CROSS(CCI,100);
HP:=HHV(H,9);
LP:=LLV(L,9);
R:=(C-LP)/(HP-LP)*100;
K:=SMA(R,3,1),COLORYELLOW,LINETHICK2;
D:=SMA(K,3,1),COLORWHITE,LINETHICK2;
J:=3*K-2*D,COLORFF9999,LINETHICK2;
買2:=CROSS(K,D);
DIF1:=EMA(CLOSE,5)-EMA(CLOSE,9),COLOR00FFFF,LINETHICK2;
DEA1:=EMA(DIF1,5),COLORFFFF00,LINETHICK2;
MACD:=2*(DIF1-DEA1);
RSV:= (HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100;
LWR1:=SMA(RSV,3,1);
LWR2:=SMA(LWR1,3,1);
買5:=CROSS(LWR2,LWR1);
買4:=CROSS(DIF1,DEA1) AND DIF1<0.3;
買6:=CROSS("PAVE.CV","PAVE.MCV");
買7:=CROSS("KD.K","KD.D") AND K<45;
買8:=CROSS("ADVOL.ADVOL","ADVOL.MA1") AND K<45;
VAR1:=HHV(HIGH,25);
VAR2:=LLV(LOW,25);
阻力線:=EMA((CLOSE-VAR2)/(VAR1-VAR2)*100,20),COLOR00FF00;
突破線:=EMA((CLOSE-VAR2)/(VAR1-VAR2)*100,5);
操作線:=突破線,COLORYELLOW,LINETHICK1;
買點:=CROSS(操作線,阻力線);
JM:=CROSS("KDJ.K"(5,3,3),"KDJ.D"(5,3,3));
JMCOUNT:=COUNT(JM,BARSLAST("KDJ.D"(5,3,3)>=30));
JMTJ:=28*("KDJ.D"(5,3,3)<30 AND COUNT(JMCOUNT=1,21)=1);
VAR11:=(HIGH+LOW+OPEN+CLOSE)/4;
生命線:=MA(3*VAR11-2*SMA(VAR11,2,1),12),,;
VAR22:=IF(VAR11<生命線,VAR11,生命線);
VAR33:=2*EMA(LLV(VAR11,7),10)-VAR11;
多空線:=3*VAR33-2*SMA(VAR33,10,1),COLORGREEN;
買9:=CROSS(生命線,多空線);VAR01:=IF(CLOSE>=REF(CLOSE,1),VOL,0);
VAR02:=IF(CLOSE<=REF(CLOSE,1),VOL,0);
VAR03:=SUM(VAR01,10);
VAR04:=SUM(VAR02,10);
VAR05:=IF(CLOSE>=MA(CLOSE,5),VOL,0);
VAR06:=IF(CLOSE<=MA(CLOSE,5),VOL,0);
VAR07:=SUM(VAR05,10);
VAR08:=SUM(VAR06,10);
VAR09:=IF(MA(CLOSE,5)>=REF(MA(CLOSE,5),1),VOL,0);
VAR0A:=IF(MA(CLOSE,5)<=REF(MA(CLOSE,5),1),VOL,0);
VAR0B:=SUM(VAR09,10);
VAR0C:=SUM(VAR0A,10);
VAR0D:=IF(EMA(CLOSE,10)>=REF(EMA(CLOSE,10),1),VOL,0);
VAR0E:=IF(EMA(CLOSE,10)<=REF(EMA(CLOSE,10),1),VOL,0);
VAR0F:=SUM(VAR0D,10);
VAR010:=SUM(VAR0E,10);
主力:=(VAR03+VAR07+VAR0B+VAR0F)/100;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS ("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS ("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
B4:=CROSS(DIFF,DEA) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
KDJ_K:="KDJ.K"(9,3,3);KDJ_D:="KDJ.D"(9,3,3);KDJ_J:="KDJ.J"(9,3,3);
買11:=CROSS(KDJ_J,0) OR (CROSS(KDJ_J,KDJ_K) AND KDJ_D<26);
買21:=CROSS("RSI.RSI1"(6,2,2),20) OR CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
買31:=CROSS("MACD.DIF","MACD.DEA") OR CROSS("MACD.MACD",0);
買0:=買1+買2+買3;
買A:=CROSS("VR.VR","VR.MAVR");
散戶:=EMA(0.667*REF(主力,1)+0.333*主力,2),LINETHICK2,COLORFF9933;
買:=(買0 + 買A + 買1 + 買2 + 買3 + 買4 + 買5 + 買6 + 買7 +買7 + 買9 + JMTJ + 買點) + ( B1 OR B2 OR B3 OR B4) + CROSS(主力,散戶);
XG:買>8;

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  排列五千神机器人软件