您現在的位置:程序化交易>> 股票公式>> 通達信>> 通達信公式>>正文內容

精準抄底指標公式--股王盤[通達信公式]

相關標簽: 最神奇的抄底逃頂公式 、 波段精準抄底指標公式 、 精準抄底短線極品指標 、 波段底頂部買賣點指標 、 波段風口指標 、

?

?

原理解析:


?

?來源:程序化99( www.946547.tw )

源碼:

?

?

?

X:=C-REF(MA(C,20),11);
LGL:=IF(EMA(C,5)/EMA(EMA(C,9),16)<=0.85 AND C/REF(C,1)>0.905 AND C/REF(C,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
WR1:=-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100*X;
WR2:=-100*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
WR3:=-100*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100*X;
BIAS1:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
BIAS2:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
BIAS3:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
S1:=(WR1+WR2+WR3+BIAS1+BIAS2+BIAS3)/6*X;
S2:=EMA(S1,3);
S3:=ABS(BIAS1-BIAS3);
SX:=(S1+S3)/2;
XC1:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
CCC:=XC1+SX;
ZJZ:=IF( LGL>0 AND CCC<0,200,0)*X;
LXL:=IF(SX<0 AND C=LLV(C,5) AND C/REF(C,1)>0.905 AND C/REF(C,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);
JBJ:=IF(CCC<0 AND LXL=-50,100,0)*X;
MA3:= MA(C,3);
C0:=REF(C,2)*0.865;
C1:=REF(C,13)*0.772;
BOT:=MIN(C0,C1);
HSL:=100*VOL/CAPITAL*X;
MA13:=MA(C,13)*X;
CXC:=IF((C-BOT)/C<3/100 AND SUM(HSL,5)/5<1.8,1,0);
VMC:=IF(CXC>0 AND (LXL<0 OR LGL>0),10,0);
滿倉:IF((VMC>0),60,0),COLORRED;
半倉:IF(((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR (CXC>0 AND REF(C,1)/REF(C,2)>0.902)) OR (((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR CXC>0) AND (LXL<0 OR LGL>0)) AND VMC<10 ,50,0);
V93:=(((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR CXC>0) AND (LXL<0 OR LGL>0)) ;
V90:=((ZJZ>0 AND JBJ>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR (CXC>0 AND REF(C,1)/REF(C,2)>0.902));
買一點:IF((V93 OR V90),10,0);
VAR2Q:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
神奇線:= MA((CLOSE-VAR2Q)/VAR2Q,1);
買二點:IF(CROSS(神奇線,0) AND LOW/REF(HIGH,1)<1.012 AND ((C-REF(C,2))/C)>0.06,20,0);
YY:=SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,18,1),12,1);
YT:=SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,12,1);
ST:=IF(CROSS(YT,YY),30,0);
VAR5PT:=(HIGH+LOW+CLOSE)/3;
VAR6PT:=(VAR5PT-MA(VAR5PT,14))/(0.015*AVEDEV(VAR5PT,14));
VAR7PT:=(VAR5PT-MA(VAR5PT,85))/(0.015*AVEDEV(VAR5PT,85));
SA:=IF(VAR7PT>=200 AND VAR6PT>=150,10,0);
VAR3QQ:=REF(CLOSE,1);
VAR4QQ:=SMA(MAX(CLOSE-VAR3QQ,0),6,1)/SMA(ABS(CLOSE-VAR3QQ),6,1)*100;
SM:=IF(CROSS(80,VAR4QQ),30,0);
賣點:IF((SM AND (SA OR ST)),30,0);

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  排列五千神机器人软件