您現在的位置:程序化交易>> 股票公式>> 通達信>> 通達信公式>>正文內容

股市藏寶圖[通達信公式]

相關標簽: 股市藏寶圖 資訊 、 騰訊新聞股市藏寶圖 、 查公眾號 股市藏寶圖 、 國家大基金二期買入的股票 、 最近股市藏寶圖 、 股市信息藏寶圖 、 股市藏寶圖每天用三張圖 、 范博股市藏寶圖 、 19年7月份股市藏寶圖 、 股票藏寶圖 、 股市行情今日大盤 、 基金重倉股票好嗎 、

?

選好股,預警50以下根據其他指標逐步建倉,50以上可加倉,賣出看自己的了

?

?

原理解析:


?

?來源:程序化99( www.946547.tw )

源碼:

?

?

?

VAR1:=1/WINNER(CLOSE);
VAR2:=MA(CLOSE,13);
VAR3:=100-ABS((CLOSE-VAR2)/VAR2*100);
VAR4:=LLV(LOW,75);
VAR5:=HHV(HIGH,75);
VAR6:=(VAR5-VAR4)/100;
VAR7:=SMA((CLOSE-VAR4)/VAR6,20,1);
VAR8:=SMA((OPEN-VAR4)/VAR6,20,1);
VAR9:=3*VAR7-2*SMA(VAR7,15,1);
VARA:=3*VAR8-2*SMA(VAR8,15,1);
VARB:=100-VARA;
VARC:=IF(900101<DATE AND DATE<9999999,1,0);
進場系數: (100-VAR9)*VARC, , {000B0001};
出貨量: MA(WINNER(CLOSE*0.95)*100,3)*VARC, , COLORYELLOW;
進貨量: (100-IF(VAR1>5,IF(VAR1<100,VAR1,VAR3-10),0))*VARC, , COLORGREEN;
VARD:=出貨量>VAR3;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
VAR21:=(HIGH+LOW+CLOSE)/3;
VAR22:=(VAR21-MA(VAR21,14))/(0.015*AVEDEV(VAR21,14));
VAR23:=(VAR21-MA(VAR21,70))/(0.015*AVEDEV(VAR21,70));
VAR24:=IF(VAR22>=150 AND VAR22<200 AND VAR23>=150 AND VAR23<200,10,0);
VAR25:=IF(VAR22<=-150 AND VAR22>-200 AND VAR23<=-150 AND VAR23>-200,-10,VAR24);
VAR26:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VAR27:=REVERSE(VAR26);
VAR28:=SMA(VAR26,3,1);
散戶: SMA(VAR28,3,1)*VARC, , COLORMAGENTA;
莊家: SMA(散戶,3,1)*VARC, , COLORYELLOW;
見頂: IF(CROSS(散戶,莊家) AND 散戶<30,莊家,0)*VARC, , COLORRED;
見底: IF(CROSS(莊家,散戶) AND 莊家>75,莊家,100)*VARC, , COLORGREEN;
DRAWTEXT(CROSS(散戶,莊家) AND 散戶<30,莊家,'低吸 !'), ,COLORWHITE;
DRAWTEXT(CROSS(莊家,散戶) AND 莊家>75,莊家,''), , COLORGREEN;
預警: (IF(VAR23>=200 AND VAR22>=150,15,IF(VAR23<=-200 AND VAR22<=-150,-15,VAR25))+50)*VARC, , {00050006};
DRAWTEXT(CROSS(VAR20,0.5) AND COUNT(VAR20=1,10)=1,35,'抄底'), , COLORYELLOW;
DRAWTEXT(CROSS(VARD,0.5) AND COUNT(VARD=1,10)=1,65,'逃頂'), , COLORCYAN;
STICKLINE(VARD,100,25,1,0), , COLORCYAN;
STICKLINE(1,出貨量,0,1,0), , COLORYELLOW;
STICKLINE(1,進貨量,100,1,0), , {00010001};
STICKLINE(VAR20,0,80,1,0), , COLORRED;

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  排列五千神机器人软件