您現在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文內容

逆市操作[大智慧公式]

相關標簽:

?

?

?

原理解析:


?

?來源:程序化99( www.946547.tw )

源碼:

?

?

?

input:K(1,1,3);
DRAWGBKLAST(C>0,STRIP(RGB(90,90,90),RGB(0,0,0),0));
DRAWTEXTREL(0,3,'代碼:'+STKLABEL),ColorFFFFFF;
MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
MA3:MA(CLOSE,30);
MA4:MA(CLOSE,60);
MA5:MA(CLOSE,120);
MA6:MA(CLOSE,250);
ema13:ema(c,13),colorblue,linethick2;
ema17:ema(c,17),colorred,linethick2;
T := BARSLAST(DISPSTATUS=1)+1;
A := DISPSTATUS=2;
HH := HHV(H, T);
LL := LLV(L, T);
HL := HH-LL;
wH := HHVBARS(H, T);
wL := LLVBARS(L, T);
KK := wH-wL;
mHL := HH-HL*0.5;
PT := REF(HIGH,1)-REF(LOW,1);
重心:=(HIGH + LOW + CLOSE)/3;
壓力Ⅰ:= 2*重心-LOW;
壓力Ⅱ:= 重心 + PT;
支撐Ⅰ:= 2*重心-HIGH;
支撐Ⅱ:= 重心 - PT;
DRAWTEXTABS(75,8,' 《逆勢操作》'),ColorFFFF00;
DRAWTEXTABS(150,8,' 重心:'+重心),Color208FFF;
DRAWTEXTABS(75,27,' 支 撐'),ColorFFFFFF;
DRAWTEXTABS(75,44,' '+支撐Ⅰ),ColorFFFFFF;
DRAWTEXTABS(75,62,' '+支撐Ⅱ),ColorFFFFFF;
DRAWTEXTABS(75,27,' 壓 力'),Color00FF00;
DRAWTEXTABS(75,44,' '+壓力Ⅰ),Color00FF00;
DRAWTEXTABS(75,62,' '+壓力Ⅱ),Color00FF00;
DRAWTEXTABS(75,5,'│'),Color00FFFF;
DRAWTEXTABS(75,17,'│'),Color00FFFF;
DRAWTEXTABS(75,29,'│'),Color00FFFF;
DRAWTEXTABS(75,41,'│'),Color00FFFF;
DRAWTEXTABS(75,53,'│'),Color00FFFF;
DRAWTEXTABS(75,65,'│'),Color00FFFF;
DRAWTEXTABS(218,5,'│'),Color00FFFF;
DRAWTEXTABS(218,17,'│'),Color00FFFF;
DRAWTEXTABS(218,29,'│'),Color00FFFF;
DRAWTEXTABS(218,41,'│'),Color00FFFF;
DRAWTEXTABS(218,53,'│'),Color00FFFF;
DRAWTEXTABS(218,65,'│'),Color00FFFF;
DRAWTEXTABS(146,25,'│'),Color00FFFF;
DRAWTEXTABS(146,29,'│'),Color00FFFF;
DRAWTEXTABS(146,41,'│'),Color00FFFF;
DRAWTEXTABS(146,53,'│'),Color00FFFF;
DRAWTEXTABS(146,65,'│'),Color00FFFF;
DRAWTEXTABS(80,0,'────────────'),Color00FFFF;
DRAWTEXTABS(80,20,'────────────'),Color00FFFF;
DRAWTEXTABS(80,37,'────────────'),Color00FFFF;
DRAWTEXTABS(80,54,'────────────'),Color00FFFF;
DRAWTEXTABS(80,71,'────────────'),Color00FFFF;WX:=MA(CLOSE,0);
STICKLINE(C>=O,C,O,8,0),COLOR0000AA;
STICKLINE(C>=O,C,O,6,0),COLOR0000bb ;
STICKLINE(C>=O,C,O,4,0),COLOR0000cc ;
STICKLINE(C>=O,C,O,2,0),COLOR0000ee;
STICKLINE(C>=O,H,L,0,0),COLOR0000ff;
STICKLINE(C<=O,C,O,8,0),Color7B7b00;
STICKLINE(C<=O,C,O,6,0),Color909000;
STICKLINE(C<=O,C,O,4,0),ColorA8a800;
STICKLINE(C<=O,C,O,2,0),COLORcece00;
STICKLINE(C<=O,H,L,0,0),COLORffff00;
G:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
X:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
DRAWTEXT(G,L*0.997,'▲'),ALIGN1,VALIGN0,Colorff00ff;
DRAWTEXT(G,L,' ̄'),ALIGN1,VALIGN0,Color00ff00;
DRAWTEXT(X,H*1.002,'▼'),ALIGN1,VALIGN2,Color00ffff;
DRAWTEXT(X,H,' ̄'),ALIGN1,VALIGN0,Color00ffff;
ED:=barslast(G);
EF:=barslast(X);
買入到賣出天數:ED,LINETHICK0,ColorFFFFFF;
賣出到買入天數:EF,LINETHICK0,ColorFFFFFF;
換手: VOL/CAPITAL*100,LINETHICK0,colorwhite;
QQ:=換手;
流通盤大小:=FINANCE2(37)/10000;
銷售毛利率:=FINANCE2(12);
主營收入同比:=FINANCE2(11);
凈利潤同比增長:=FINANCE2(10);
當日換手率:=sum(100*v/capital,1);
三日換手率:=sum(100*v/capital,3);
五日換手率:=sum(100*v/capital,5);
市盈率 := dynainfo(39);
現價 := dynainfo(7);
EMA13 := EMA(CLOSE,13);
EMA17:= EMA(CLOSE,17);
diff13:= (現價/EMA13 - 1)*100;
diff17:= (現價/EMA17 - 1)*100;
DRAWTEXTREL(480,90,'今日買點:'+NUMTOSTRN(EMA((o+h+l)/3,4),2 )),LINETHICK2,coloryellow;
DRAWTEXTABS(220,10,'所屬板塊:'+BKNAME),COLORred;
DRAWTEXTABS(350,25,'市盈率:'+市盈率+' '),LINETHICK1,colorwhite;
DRAWTEXTABS(220,25,'流通盤大?。?+流通盤大小+'億 '),LINETHICK1,colorwhite;
DRAWTEXTABS(220,40,'銷售毛利率:'+銷售毛利率+'% '),LINETHICK1,colorwhite;
DRAWTEXTABS(350,40,'主營收入同比:'+主營收入同比+' '),LINETHICK1,colorwhite;
DRAWTEXTABS(220,55,'凈利潤同比增長:'+凈利潤同比增長+'% '),LINETHICK1,colorwhite;
DRAWTEXTABS(220,70,'當日換手: '+NUMTOSTRN(當日換手率,2)+'%'),colorwhite,LINETHICK1;
DRAWTEXTABS(350,70,'三日換手: '+NUMTOSTRN(三日換手率,2)+'%'),colorwhite,LINETHICK1;
DRAWTEXTREL(0,910,' 買入到到當前周期:'+NUMTOSTR(ED) +'天'+' 賣出到當前周期:'+NUMTOSTR(EF) +'天'+' 換手率:'+NUMTOSTRN(QQ,2) +'%'),colorFfff00;

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  排列五千神机器人软件