您現在的位置:程序化交易>> 期貨公式>> 交易開拓者(TB)>> 開拓者公式>>正文內容

回抽開倉多空模型源碼 開拓者TB 文華通用[開拓者公式]

  • 開拓者源碼:

    Params
        Numeric lenth(10);
        Numeric Lots(1);
        Numeric ExitOnCloseMins(15.10);
     
    Vars
        Numeric H1;
        Numeric H2;
        Numeric H3;
        Numeric L1;
        Numeric L2;
        Numeric L3;
        Numeric HH;
        Numeric LL;
        Numeric Stopline;
        Numeric C1;
        Numeric C2;
        Numeric C3;

    Begin
        H1=H[1];
        H2=H[2];
        H3=H[3];
        L1=L[1];
        L2=L[2];
        L3=L[3];

        HH=Highest(High[1],Lenth);
        LL=Lowest(Low[1],lenth);
        If(H1<H2 && H2>H3 && H1>H3 && High>=H2  && MarketPosition!=1)
        {
            Buy(Lots,Max(Open,H2));
            Return;
        }
        If(L1>L2 && L2<L3 && L1<L3 &&  Low<=L2 && MarketPosition!=-1)
        {
            SellShort(Lots,Min(Open,L2));
            Return;
        }
     
     
        If(MarketPosition==1 && L<=LL  && BarsSinceEntry>0)Sell(Lots,Min(Open,LL));
        If(MarketPosition==-1 && H>=HH && BarsSinceEntry>0)BuyToCover(Lots,Max(Open,HH));
     
        If(Time >=ExitOnCloseMins/100)
        {
            Sell(0,Open);
            BuyToCover(0,Open);
       
    End

     

 

  • 文華財經WH3 源碼:

     

    H1:=REF(H,1);
    H2:=REF(H,2);
    H3:=REF(H,3);
    L1:=REF(L,1);
    L2:=REF(L,2);
    L3:=REF(L,3);
    HH:=HHV(H1,10);
    LL:=LLV(L1,10);
    H1<H2 && H2>H3 && H1>H3 && HIGH>=H2,BK;
    L1>L2 && L2<L3 && L1<L3 && LOW<=L2,SK;
    L<=LL||TIME>=1510,SP;
    H>=HH||TIME>=1510,BP;
    AUTOFILTER;

 

有思路,想編寫各種指標公式,程序化交易模型,選股公式,預警公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流進行 有償 編寫!不貴!點擊查看價格!

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  排列五千神机器人软件